GitHub Advisoryadvisory · RubyGems

GHSA-fqfj-cmh6-hj49 ruby-openid SSRF via claimed_id request

CRITICAL Published 2019-06-13 Modified 2023-07-05 Official page ↗
Aliases
CVE-2019-11027
Ecosystem
RubyGems
Packages
ruby-openid
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-918
Reviewed
2019-06-13

Affected packages

• RubyGems ruby-openid: < 2.9.0 → fixed in 2.9.0

Description

Ruby OpenID (aka ruby-openid) through 2.8.0 is vulnerable to SSRF. Ruby-openid performs discovery first, and then verification. This allows an attacker to change the URL used for discovery and trick the server into connecting to the URL, which might be a private server not publicly accessible. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the "example app" provided by the project are at highest risk.

Related

Alias · CVE (1)

  • CVE-2019-11027 Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References