GitHub Advisoryadvisory · Maven
GHSA-fqg2-c97r-rqcj Exposure of Sensitive Information in Jenkins Kubernetes Plugin
HIGH
Official page ↗
- Aliases
- CVE-2018-1999040
- Ecosystem
- Maven
- Packages
- org.csanchez.jenkins.plugins:kubernetes
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-200
- Reviewed
- 2022-11-03
Affected packages
• Maven org.csanchez.jenkins.plugins:kubernetes: < 1.10.2 → fixed in 1.10.2
Description
An exposure of sensitive information vulnerability exists in Jenkins Kubernetes Plugin 1.10.1 and earlier in KubernetesCloud.java that allows attackers to capture credentials with a known credentials ID stored in Jenkins.
Related
Alias · CVE (1)
- CVE-2018-1999040 An exposure of sensitive information vulnerability exists in Jenkins Kubernetes Plugin 1.10.1 and earlier in KubernetesCloud.java that… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness