GitHub Advisoryadvisory · PyPI

GHSA-fqxj-46wg-9v84 Flask-AppBuilder's OAuth login page subject to Cross Site Scripting (XSS)

MEDIUM Published 2024-02-28 Modified 2025-04-01 Official page ↗
Aliases
CVE-2024-27083
Ecosystem
PyPI
Packages
Flask-AppBuilder
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Weaknesses
CWE-79
Reviewed
2024-02-28

Affected packages

• PyPI Flask-AppBuilder: >= 4.1.4, < 4.2.1 → fixed in 4.2.1

Description

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered on the OAuth login page. An attacker could trick a user to follow a specially crafted URL to the OAuth login page. This URL could inject and execute malicious javascript code that would get executed on the user's browser. Impacted versions: Flask-AppBuilder version 4.1.4 up to and including 4.2.0 Patches This issue was introduced on 4.1.4 and patched on 4.2.1, user's should upgrade to 4.2.1 or newer versions.

Related

Alias · CVE (1)

  • CVE-2024-27083 Flask-AppBuilder is an application development framework, built on top of Flask. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References