GitHub Advisoryadvisory · Go
GHSA-fr22-5377-f3p7 Mattermost Playbooks fails to properly validate permissions
LOW
Official page ↗
- Aliases
- CVE-2025-41423
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-plugin-playbooks, github.com/mattermost/mattermost/server/v8
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-04-24
Affected packages
• Go github.com/mattermost/mattermost-plugin-playbooks: < 2.1.1 (no fix yet)
• Go github.com/mattermost/mattermost-plugin-playbooks: < 1.41.0 → fixed in 1.41.0
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250218121836-2b5275d87136 → fixed in 8.0.0-20250218121836-2b5275d87136
• Go github.com/mattermost/mattermost/server/v8: < 10.4.3 (no fix yet)
• Go github.com/mattermost/mattermost/server/v8: < 10.5.1 (no fix yet)
• Go github.com/mattermost/mattermost/server/v8: < 9.11.11 (no fix yet)
Description
Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate permissions for the API endpoint /plugins/playbooks/api/v0/signal/keywords/ignore-thread, allowing any user or attacker to delete posts containing actions created by the Playbooks bot, even without channel access or appropriate permissions.
Related
Alias · CVE (1)
- CVE-2025-41423 Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate permissions for the API endpoint… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-41423 advisory
- https://github.com/mattermost/mattermost-plugin-playbooks/commit/f9f7064e4d9f3918d66bac1f5f9eb28f0723464b web
- https://github.com/mattermost/mattermost/commit/2b5275d87136f07e016c8eca09a2f004b31afc8a web
- https://github.com/mattermost/mattermost-plugin-playbooks package
- https://mattermost.com/security-updates web