GitHub Advisoryadvisory · RubyGems
GHSA-fr32-gr5c-xq5c RubyGems Escape sequence injection vulnerability in verbose
HIGH
Official page ↗
- Aliases
- CVE-2019-8321
- Ecosystem
- RubyGems
- Packages
- rubygems-update
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-88
- Reviewed
- 2019-06-20
Affected packages
• RubyGems rubygems-update: >= 2.6.0, < 2.7.9 → fixed in 2.7.9
• RubyGems rubygems-update: >= 3.0.0, < 3.0.2 → fixed in 3.0.2
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.
Related
Alias · CVE (1)
- CVE-2019-8321 An issue was discovered in RubyGems 2.6 and later through 3.0.2. vulnerability
Weakness · CWE (1)
- CWE-88 Improper Neutralization of Argument Delimiters in a Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-8321 advisory
- https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2019-8321.yml web
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html web
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html web