GitHub Advisoryadvisory · Packagist

GHSA-fr9m-pjmm-qx9f Moodle allows attackers to obtain sensitive calendar-event information

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-0215
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-200
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.6.7 → fixed in 2.6.7 • Packagist moodle/moodle: >= 2.7.0, < 2.7.4 → fixed in 2.7.4 • Packagist moodle/moodle: >= 2.8.0, < 2.8.2 → fixed in 2.8.2

Description

calendar/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to obtain sensitive calendar-event information via a web-services request.

Related

Alias · CVE (1)

  • CVE-2015-0215 calendar/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References