GitHub Advisoryadvisory · Packagist

GHSA-frm9-7pm9-5rgc SilverStripe comments module includes version of jQuery vulnerable to Cross-site Scripting

MEDIUM Published 2024-05-27 Modified 2024-05-27 Official page ↗
Ecosystem
Packagist
Packages
silverstripe/comments
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-05-27

Affected packages

• Packagist silverstripe/comments: >= 1.3.0, < 3.1.1 → fixed in 3.1.1

Description

The silverstripe/comments module, the cwp/starter-theme and the cwp/watea-theme include an outdated version of jQuery by default, which contains XSS vulnerabilities if user input is used in certain contexts. Though no known exploit has been found for these in the existing usage, user customisation to these themes could have made them exploitable. CWP 2.0.0 has been released with the fixed cwp/stater-theme and silverstripe/comments module, and SilverStripe 4.2.0 will be released with the fixed silverstripe-themes/simple theme.

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References