GitHub Advisoryadvisory · PyPI

GHSA-frmv-pr5f-9mcr Django vulnerable to SQL injection via _connector keyword argument in QuerySet and Q objects.

CRITICAL Published 2025-11-05 Modified 2026-06-05 Official page ↗
Aliases
CVE-2025-64459
Ecosystem
PyPI
Packages
django
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-89
Reviewed
2025-11-05

Affected packages

• PyPI django: >= 5.2a1, < 5.2.8 → fixed in 5.2.8 • PyPI django: >= 5.0a1, < 5.1.14 → fixed in 5.1.14 • PyPI django: < 4.2.26 → fixed in 4.2.26

Description

An issue was discovered in 5.1 before 5.1.14, 4.2 before 4.2.26, and 5.2 before 5.2.8. The methods `QuerySet.filter()`, `QuerySet.exclude()`, and `QuerySet.get()`, and the class `Q()`, are subject to SQL injection when using a suitably crafted dictionary, with dictionary expansion, as the `_connector` argument. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank cyberstan for reporting this issue.

Related

Alias · CVE (1)

  • CVE-2025-64459 An issue was discovered in 5.1 before 5.1.14, 4.2 before 4.2.26, and 5.2 before 5.2.8. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References