GitHub Advisoryadvisory · RubyGems
GHSA-frp2-5qfc-7r8m request_store has Incorrect Default Permissions
MEDIUM
Official page ↗
- Aliases
- CVE-2024-43791
- Ecosystem
- RubyGems
- Packages
- request_store
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-276
- Reviewed
- 2024-08-23
Affected packages
• RubyGems request_store: >= 1.3.2, < 1.4.0 → fixed in 1.4.0
Description
Impact
The files published as part of request_store 1.3.2 have 0666 permissions, meaning that they are world-writable, which allows local users to execute arbitrary code.
This version was published in 2017, and most production environments do not allow access for local users, so the chances of this being exploited are very low, given that the vast majority of users will have upgraded, and those that have not, if any, are not likely to be exposed.
Patches
I am not aware of any other version of the gem with incorrect permissions, so simply upgrading should fix the issue.
Workarounds
You could chmod the files yourself, I guess.
References
https://cwe.mitre.org/data/definitions/276.html
Related
Alias · CVE (1)
- CVE-2024-43791 RequestStore provides per-request global storage for Rack. vulnerability
Weakness · CWE (1)
- CWE-276 Incorrect Default Permissions weakness