GitHub Advisoryadvisory · Packagist

GHSA-frv8-xjcp-hrm2 phpMyAdmin Cross-site Scripting vulnerability

MEDIUM Published 2022-05-17 Modified 2025-04-12 Official page ↗
Aliases
CVE-2010-2958
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Weaknesses
CWE-79
Reviewed
2025-04-12

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 3.0.0, < 3.3.6 → fixed in 3.3.6

Description

Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.

Related

Alias · CVE (1)

  • CVE-2010-2958 Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References