GitHub Advisoryadvisory · PyPI
GHSA-frxj-5j27-f8rf Externally Controlled Reference to a Resource in Another Sphere, Improper Input Validation, and External Control of File Name or Path in Ansible
HIGH
Official page ↗
- Aliases
- CVE-2019-14905
- Ecosystem
- PyPI
- Packages
- ansible
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L
- Weaknesses
- CWE-20, CWE-610, CWE-668, CWE-73
- Reviewed
- 2021-04-05
Affected packages
• PyPI ansible: >= 2.7.0a1, < 2.7.16 → fixed in 2.7.16
• PyPI ansible: >= 2.8.0a1, < 2.8.8 → fixed in 2.8.8
• PyPI ansible: >= 2.9.0a1, < 2.9.3 → fixed in 2.9.3
Description
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.
Related
Alias · CVE (1)
- CVE-2019-14905 A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-14905 advisory
- https://access.redhat.com/errata/RHSA-2020:0216 web
- https://access.redhat.com/errata/RHSA-2020:0218 web
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14905 web
- https://github.com/advisories/GHSA-frxj-5j27-f8rf advisory
- https://github.com/ansible/ansible package
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-206.yaml web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/5BNCYPQ4BY5QHBCJOAOPANB5FHATW2BR web
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html web
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html web