GitHub Advisoryadvisory · PyPI
GHSA-frxx-2m33-6wcr Improper Restriction of Operations within the Bounds of a Memory Buffer in Google TensorFlow
HIGH
Official page ↗
- Aliases
- CVE-2018-8825
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-gpu
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-119
- Reviewed
- 2019-04-24
Affected packages
• PyPI tensorflow: >= 1.5.0, < 1.7.1 → fixed in 1.7.1
• PyPI tensorflow-gpu: >= 1.5.0, < 1.7.1 → fixed in 1.7.1
Description
Google TensorFlow 1.7 and below is affected by: Buffer Overflow. The impact is: execute arbitrary code (local). Users passing a malformed or malicious version of a TFLite graph into TOCO will cause TOCO to crash or cause a buffer overflow, potentially allowing malicious code to be executed.
Related
Alias · CVE (1)
- CVE-2018-8825 Google TensorFlow 1.7 and below is affected by: Buffer Overflow. vulnerability
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-8825 advisory
- https://github.com/tensorflow/tensorflow/commit/41335abb46f80ca644b5738550daef6136ba5476 web
- https://github.com/tensorflow/tensorflow/commit/8badd11d875a826bd318ed439909d5c47a7fb811 web
- https://github.com/advisories/GHSA-frxx-2m33-6wcr advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-226.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-233.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-208.yaml web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-003.md web