GitHub Advisoryadvisory · Packagist

GHSA-fv26-4939-62fh phpVMS has an /importer authorization bypass causing full database wipe

CRITICAL Published 2026-05-04 Modified 2026-05-13 Official page ↗
Aliases
CVE-2026-42569
Ecosystem
Packagist
Packages
nabeel/phpvms
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
Weaknesses
CWE-284, CWE-306, CWE-862
Reviewed
2026-05-04

Affected packages

• Packagist nabeel/phpvms: < 7.0.6 → fixed in 7.0.6

Description

Security Advisory: Unauthenticated Access to Legacy Import Feature Severity: Critical Affected versions: phpVMS 7.x (up to 7.0.5) Fixed in: v7.0.6 Component: Legacy importer Summary A critical vulnerability in phpVMS 7.x allowed unauthenticated access to a legacy import feature. Although this feature is deprecated, parts of it remained accessible and operational. Impact A remote attacker could trigger internal processes that modify or delete application data, potentially resulting in: • Data loss • Service disruption No authentication was required. Remediation • Update immediately to the latest patched version • If unable to update: • The release link has instructions on how to fix it (it's a one-line fix to comment out the routes) Affected Versions • Affected: phpVMS 7.x ≤ 7.0.5 • Not affected: phpVMS >= 7.0.6, v8 (feature removed from public access)

Related

Alias · CVE (1)

  • CVE-2026-42569 phpVMS is a PHP application to run and simulate an airline. vulnerability

Weakness · CWE (3)

  • CWE-284 Improper Access Control weakness
  • CWE-306 Missing Authentication for Critical Functionality weakness
  • CWE-862 Missing Authorization weakness

References