GitHub Advisoryadvisory · NuGet

GHSA-fv2h-753j-9g39 Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation

HIGH Published 2023-09-20 Modified 2024-10-11 Official page ↗
Aliases
CVE-2023-41890
Ecosystem
NuGet
Packages
Sustainsys.Saml2, Kentor.AuthServices
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-289, CWE-294
Reviewed
2023-09-20

Affected packages

• NuGet Sustainsys.Saml2: < 1.0.3 → fixed in 1.0.3 • NuGet Sustainsys.Saml2: >= 2.0.0, < 2.9.2 → fixed in 2.9.2 • NuGet Kentor.AuthServices: <= 0.23.0 (no fix yet)

Description

Impact When a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: • the issuer of the generated identity and claims • items in the stored request state (AuthenticationProperties) Patches Patched in version 2.9.2 and 1.0.3. All previous versions are vulnerable. Workarounds The `AcsCommandResultCreated` notification can be used to add the validation required if an upgrade to patched packages is not possible. References The patch is linked to https://github.com/Sustainsys/Saml2/issues/712 and https://github.com/Sustainsys/Saml2/issues/713

Related

Alias · CVE (1)

  • CVE-2023-41890 Sustainsys.Saml2 library adds SAML2P support to ASP.NET web sites, allowing the web site to act as a SAML2 Service Provider. vulnerability

Weakness · CWE (2)

  • CWE-289 Authentication Bypass by Alternate Name weakness
  • CWE-294 Authentication Bypass by Capture-replay weakness

References