GitHub Advisoryadvisory · Go
GHSA-fv4g-gwpj-74gr Path traversal vulnerability in stripe-cli
LOW
Official page ↗
- Aliases
- CVE-2024-45401
- Ecosystem
- Go
- Packages
- github.com/stripe/stripe-cli
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-22
- Reviewed
- 2024-09-05
Affected packages
• Go github.com/stripe/stripe-cli: >= 1.11.1, < 1.21.3 → fixed in 1.21.3
Description
Impact
A vulnerability exists in stripe-cli versions 1.11.1 and higher where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files.
The update addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path.
There has been no evidence of exploitation of this vulnerability.
Recommendation
Upgrade to stripe-cli v1.21.3.
Acknowledgements
Thank you to 0xacb and bordiez for reporting this vulnerability.
For more information
Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2024-45401 stripe-cli is a command-line tool for the payment processor Stripe. vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness