GitHub Advisoryadvisory · Packagist
GHSA-fv7m-wc3v-wr3w SimpleSAMLphp XSS Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2017-18121
- Ecosystem
- Packagist
- Packages
- simplesamlphp/simplesamlphp
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-26
Affected packages
• Packagist simplesamlphp/simplesamlphp: >= 1.12.0, < 1.14.16 → fixed in 1.14.16
Description
The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.
Related
Alias · CVE (1)
- CVE-2017-18121 The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-18121 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2017-18121.yaml web
- https://lists.debian.org/debian-lts-announce/2018/02/msg00008.html web
- https://simplesamlphp.org/security/201709-01 web
- https://www.debian.org/security/2018/dsa-4127 web