GitHub Advisoryadvisory · npm

GHSA-fvcj-hvfw-7f2v botframework-connector vulnerable to Improper Authentication

MEDIUM Published 2021-03-08 Modified 2024-01-02 Official page ↗
Aliases
CVE-2021-1725
Ecosystem
npm
Packages
botframework-connector
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200, CWE-287
Reviewed
2021-03-08

Affected packages

• npm botframework-connector: >= 4.7.0, < 4.7.3 → fixed in 4.7.3 • npm botframework-connector: >= 4.8.0, < 4.8.1 → fixed in 4.8.1 • npm botframework-connector: >= 4.9.0, < 4.9.4 → fixed in 4.9.4 • npm botframework-connector: >= 4.10.0, < 4.10.3 → fixed in 4.10.3

Description

Impact A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot. Patches The problem has been patched in all affected versions. Please see the list of patched versions for the most appropriate one for your individual case. Workarounds Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if the Claims are Skill Claims. For detailed instructions, see the link in the References section. For more information If you have any questions or comments about this advisory: • Open an issue in Microsoft Bot Builder SDK • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2021-1725 Bot Framework SDK Information Disclosure Vulnerability vulnerability

Weakness · CWE (2)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
  • CWE-287 Improper Authentication weakness

References