GitHub Advisoryadvisory · PyPI

GHSA-fvxv-9xxr-h7wj Pyspark User Impersonation Vulnerability

MEDIUM Published 2019-02-07 Modified 2024-10-24 Official page ↗
Aliases
CVE-2018-11760
Ecosystem
PyPI
Packages
pyspark
Severity
Moderate
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Reviewed
2020-06-16

Affected packages

• PyPI pyspark: >= 2.3.0, < 2.3.2 → fixed in 2.3.2 • PyPI pyspark: >= 1.0.2, < 2.2.3 → fixed in 2.2.3

Description

When using PySpark , it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application. This affects versions 1.x, 2.0.x, 2.1.x, 2.2.0 to 2.2.2, and 2.3.0 to 2.3.1.

Related

Alias · CVE (1)

  • CVE-2018-11760 When using PySpark , it's possible for a different local user to connect to the Spark application and impersonate the user running the… vulnerability

References