GitHub Advisoryadvisory · Go

GHSA-fw33-qpx7-rhx2 gardenctl is vulnerable to Command Injection when used with non‑POSIX shells

HIGH Published 2025-12-11 Modified 2026-03-24 Official page ↗
Aliases
CVE-2025-67508
Ecosystem
Go
Packages
github.com/gardener/gardenctl-v2
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2025-12-11

Affected packages

• Go github.com/gardener/gardenctl-v2: < 0.0.0-20251107111549-0bdc484cb5fb → fixed in 0.0.0-20251107111549-0bdc484cb5fb

Description

A security vulnerability was discovered in gardenctl when it is used with non‑POSIX shells such as Fish and PowerShell. Such setup could allow an attacker with administrative privileges for a Gardener project to craft malicious credential values in infrastructure Secret objects that break out of the intended string context when evaluated in Fish or PowerShell environments used by the Gardener service operators, leading to arbitrary command execution on the operator's device. Am I vulnerable? This CVE affects all Gardener operators who use gardenctl < v2.12.0 with non‑POSIX shells such as Fish and PowerShell.

Related

Alias · CVE (1)

  • CVE-2025-67508 gardenctl is a command-line client for the Gardener which configures access to clusters and cloud provider CLI tools. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References