GitHub Advisoryadvisory · PyPI

GHSA-fwfg-vprh-97ph OctoPrint vulnerable to Improper Neutralization of Special Elements Used in a Template Engine

HIGH Published 2023-10-10 Modified 2024-10-07 Official page ↗
Aliases
CVE-2023-41047
Ecosystem
PyPI
Packages
OctoPrint
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-1336
Reviewed
2023-10-10

Affected packages

• PyPI OctoPrint: < 1.9.3 → fixed in 1.9.3

Description

Impact OctoPrint versions up until and including 1.9.2 contain a vulnerability that allows malicious admins to configure a specially crafted GCODE script through the Settings that will allow code execution during rendering of that script. An attacker might use this to extract data managed by OctoPrint, or manipulate data managed by OctoPrint, as well as execute arbitrary commands with the rights of the OctoPrint process on the server system. Please note that GCODE files uploaded to be printed are *not* affected! This vulnerability exclusively affects GCODE Scripts to be executed on connection to the printer, print pause, resume etc, as described in the documentation, to be found under Settings > GCODE Scripts and configurable only by users with the `ADMIN` permission. Patches The vulnerability has been patched in version 1.9.3. Workarounds OctoPrint administrators are strongly advised to thoroughly vet who has admin access to their installation and to not blindly configure arbitrary GCODE scripts found online or provided to them by third parties. Credits This vulnerability was discovered and responsibly disclosed to OctoPrint by tianxin Wu (Bearcat), Vulnerability Researcher at Numen Cyber Labs, Singapore.

Related

Alias · CVE (1)

  • CVE-2023-41047 OctoPrint is a web interface for 3D printers. vulnerability

Weakness · CWE (1)

  • CWE-1336 Improper Neutralization of Special Elements Used in a Template Engine weakness

References