GitHub Advisoryadvisory · Maven
GHSA-fwqr-3pvp-pjwq Deserialization of Untrusted Data in Jenkins
HIGH
Official page ↗
- Aliases
- CVE-2017-2608
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2022-07-01
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.32.2 → fixed in 2.32.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.34, < 2.44 → fixed in 2.44
Description
Jenkins before versions 2.44, 2.32.2 is vulnerable to a remote code execution vulnerability involving the deserialization of various types in javax.imageio in XStream-based APIs (SECURITY-383).
Related
Alias · CVE (1)
- CVE-2017-2608 Jenkins before versions 2.44, 2.32.2 is vulnerable to a remote code execution vulnerability involving the deserialization of various types… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-2608 advisory
- https://github.com/jenkinsci/jenkins/commit/a814154695e23dc37542af7d40cacc129cf70722 web
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2608 web
- https://github.com/jenkinsci/jenkins package
- https://jenkins.io/security/advisory/2017-02-01 web
- http://www.securityfocus.com/bid/95953 web