GitHub Advisoryadvisory · npm
GHSA-fx49-4h83-wjv9 Payload didn't enforce field-level password update restrictions
HIGH
Official page ↗
- Aliases
- CVE-2026-105855
- Ecosystem
- npm
- Packages
- payload
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-284
- Reviewed
- 2026-10-06
Affected packages
• npm payload: < 3.90.0 → fixed in 3.90.0
• npm payload: >= 4.0.0-canary.0, < 4.0.0-canary.34 → fixed in 4.0.0-canary.34
Description
Impact
When an auth collection defined a field-level access.update restriction on the password field, the restriction was not enforced on the server correctly.
Patches
Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.
Related
Alias · CVE (1)
- CVE-2026-105855 Payload is a free and open source headless content management system. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness