GitHub Advisoryadvisory · Packagist

GHSA-fx5h-3786-h2w6 PHP Spellchecker addon for TinyMCE allows attackers to trigger arbitrary outbound HTTP requests

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2012-6112
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: >= 2.1.0, < 2.1.10 → fixed in 2.1.10 • Packagist moodle/moodle: >= 2.2.0, < 2.2.7 → fixed in 2.2.7 • Packagist moodle/moodle: >= 2.3.0, < 2.3.4 → fixed in 2.3.4 • Packagist moodle/moodle: >= 2.4.0, < 2.4.1 → fixed in 2.4.1

Description

classes/GoogleSpell.php in the PHP Spellchecker (aka Google Spellchecker) addon before 2.0.6.1 for TinyMCE, as used in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 and other products, does not properly handle control characters, which allows remote attackers to trigger arbitrary outbound HTTP requests via a crafted string.

Related

Alias · CVE (1)

  • CVE-2012-6112 classes/GoogleSpell.php in the PHP Spellchecker (aka Google Spellchecker) addon before 2.0.6.1 for TinyMCE, as used in Moodle 2.1.x before… vulnerability

References