GitHub Advisoryadvisory · Maven
GHSA-fxj8-cqcp-3vgq Jenkins cross-site scripting (XSS) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2014-2065
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- Weaknesses
- CWE-79
- Reviewed
- 2024-03-05
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: >= 1.533, < 1.551 → fixed in 1.551
• Maven org.jenkins-ci.main:jenkins-core: < 1.532.2 → fixed in 1.532.2
Description
Cross-site scripting (XSS) vulnerability in Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to inject arbitrary web script or HTML via the iconSize cookie.
Related
Alias · CVE (1)
- CVE-2014-2065 Cross-site scripting (XSS) vulnerability in Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to inject arbitrary web… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-2065 advisory
- https://github.com/jenkinsci/jenkins/commit/a0b00508eeb74d7033dc4100eb382df4e8fa72e7 web
- https://github.com/jenkinsci/jenkins package
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-02-14 web
- http://www.openwall.com/lists/oss-security/2014/02/21/2 web