GitHub Advisoryadvisory · PyPI
GHSA-fxjm-wvj9-9c39 Information disclosure in Apache Superset
MEDIUM
Official page ↗
- Aliases
- CVE-2020-1932
- Ecosystem
- PyPI
- Packages
- apache-superset
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2020-02-25
Affected packages
• PyPI apache-superset: >= 0.34.0, < 0.35.2 → fixed in 0.35.2
Description
An information disclosure issue was found in Apache Superset 0.34.0, 0.34.1, 0.35.0, and 0.35.1. Authenticated Apache Superset users are able to retrieve other users' information, including hashed passwords, by accessing an unused and undocumented API endpoint on Apache Superset.
Related
Alias · CVE (1)
- CVE-2020-1932 An information disclosure issue was found in Apache Superset 0.34.0, 0.34.1, 0.35.0, and 0.35.1. vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-1932 advisory
- https://github.com/apache/superset package
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-superset/PYSEC-2020-224.yaml web
- https://lists.apache.org/thread.html/r4e5323c3bc786005495311a6ff53ac6d990b2c7eb52941a1a13ce227%40%3Cdev.superset.apache.org%3E web