GitHub Advisoryadvisory · PyPI

GHSA-fxqx-xgqq-gf42 Exposure of Sensitive Information in EVE-SRP

MEDIUM Published 2023-02-06 Modified 2024-09-20 Official page ↗
Aliases
CVE-2020-36660
Ecosystem
PyPI
Packages
EVE-SRP
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-200
Reviewed
2023-02-15

Affected packages

• PyPI EVE-SRP: < 0.12.12 → fixed in 0.12.12

Description

A vulnerability was found in paxswill EVE Ship Replacement Program 0.12.11. It has been rated as problematic. This issue affects some unknown processing of the file src/evesrp/views/api.py of the component User Information Handler. The manipulation leads to information disclosure. The attack may be initiated remotely. Upgrading to version 0.12.12 is able to address this issue. The name of the patch is 9e03f68e46e85ca9c9694a6971859b3ee66f0240. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220211.

Related

Alias · CVE (1)

  • CVE-2020-36660 A vulnerability was found in paxswill EVE Ship Replacement Program 0.12.11. vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References