GitHub Advisoryadvisory · RubyGems
GHSA-fxwv-953p-7qpf Phusion Passenger allows remote attackers to spoof headers
LOW
Official page ↗
- Aliases
- CVE-2015-7519
- Ecosystem
- RubyGems
- Packages
- passenger
- Severity
- Low
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• RubyGems passenger: < 4.0.60 → fixed in 4.0.60
• RubyGems passenger: >= 5.0.0, < 5.0.22 → fixed in 5.0.22
Description
`agent/Core/Controller/SendRequest.cpp` in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in standalone mode without a filtering proxy, allows remote attackers to spoof headers passed to applications by using an `_` (underscore) character instead of a `-` (dash) character in an HTTP header, as demonstrated by an `X_User` header.
Related
Alias · CVE (1)
- CVE-2015-7519 agent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-7519 advisory
- https://github.com/phusion/passenger/commit/ddb8ecc4ebf260e4967f57f271d4f5761abeac3e web
- https://blog.phusion.nl/2015/12/07/cve-2015-7519 web
- https://bugzilla.suse.com/show_bug.cgi?id=956281 web
- https://github.com/advisories/GHSA-fxwv-953p-7qpf advisory
- https://github.com/phusion/passenger package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/passenger/CVE-2015-7519.yml web
- https://lists.debian.org/debian-lts-announce/2018/06/msg00007.html web
- https://web.archive.org/web/20220327073056/https://www.puppet.com/security/cve/passenger-dec-2015-security-fixes web
- http://lists.opensuse.org/opensuse-security-announce/2015-12/msg00024.html web
- http://www.openwall.com/lists/oss-security/2015/12/07/1 web
- http://www.openwall.com/lists/oss-security/2015/12/07/2 web