GitHub Advisoryadvisory · Go
GHSA-g24c-fx4v-xg9w Mattermost Server has Insufficient Session Expiration when used as an OAuth 2.0 service provider
MEDIUM
Official page ↗
- Aliases
- CVE-2017-18905
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-613
- Reviewed
- 2026-01-12
Affected packages
• Go github.com/mattermost/mattermost-server: < 3.9.2 → fixed in 3.9.2
• Go github.com/mattermost/mattermost-server: >= 3.10.0, < 3.10.2 → fixed in 3.10.2
Description
An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when used as an OAuth 2.0 service provider, Session invalidation was mishandled.
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2017-18905 An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when used as an OAuth 2.0 service provider, Session… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-18905 advisory
- https://github.com/mattermost/mattermost/commit/15ad24d160cb4604d0605ebbfa53d11a57820706 web
- https://github.com/mattermost/mattermost/commit/b17fca0d5ee7557e3df1cf1d1da8bd749859e35f web
- https://github.com/mattermost/mattermost/commit/fbc170733e86f09b46ba754dd03304733d2f482f web
- https://github.com/mattermost/mattermost package
- https://mattermost.com/security-updates web