GitHub Advisoryadvisory · PyPI
GHSA-g26j-5385-hhw3 LiteLLM Server-Side Request Forgery (SSRF) vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2024-6587
- Ecosystem
- PyPI
- Packages
- litellm
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2024-09-13
Affected packages
• PyPI litellm: < 1.44.8 → fixed in 1.44.8
Description
A Server-Side Request Forgery (SSRF) vulnerability exists in berriai/litellm version 1.38.10. This vulnerability allows users to specify the `api_base` parameter when making requests to `POST /chat/completions`, causing the application to send the request to the domain specified by `api_base`. This request includes the OpenAI API key. A malicious user can set the `api_base` to their own domain and intercept the OpenAI API key, leading to unauthorized access and potential misuse of the API key.
Related
Alias · CVE (1)
- CVE-2024-6587 A Server-Side Request Forgery (SSRF) vulnerability exists in berriai/litellm version 1.38.10. vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness