GitHub Advisoryadvisory · RubyGems
GHSA-g28x-pgr3-qqx6 Octokit gem published with world-writable files
LOW
Official page ↗
- Aliases
- CVE-2022-31072
- Ecosystem
- RubyGems
- Packages
- octokit
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-276
- Reviewed
- 2022-06-15
Affected packages
• RubyGems octokit: >= 4.23.0, < 4.25.0 → fixed in 4.25.0
Description
Impact
Versions 4.23.0 and 4.24.0 of the octokit gem were published containing world-writeable files.
Specifically, the gem was packed with files having their permissions set to `-rw-rw-rw-` (i.e. 0666) instead of `rw-r--r--` (i.e. 0644). This means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem.
Malicious code already present and running on your machine, separate from this package, could modify the gem’s files and change its behavior during runtime.
Patches
• octokit 4.25.0
Workarounds
Users can use the previous version of the gem v4.22.0. Alternatively, users can modify the file permissions manually until they are able to upgrade to the latest version.
Related
Alias · CVE (1)
- CVE-2022-31072 Octokit is a Ruby toolkit for the GitHub API. vulnerability
Weakness · CWE (1)
- CWE-276 Incorrect Default Permissions weakness
References
- https://github.com/octokit/octokit.rb/security/advisories/GHSA-g28x-pgr3-qqx6 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-31072 advisory
- https://github.com/octokit/octokit.rb/commit/1c8edecc9cf23d1ceb959d91a416a69f55ce7d55 web
- https://github.com/octokit/octokit.rb package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/octokit/CVE-2022-31072.yml web