GitHub Advisoryadvisory · Packagist

GHSA-g2vx-8v47-4vhh CakePHP allows remote attackers to modify internal Cake cache and execute arbitrary code

HIGH Published 2022-05-17 Modified 2023-01-14 Official page ↗
Aliases
CVE-2010-4335
Ecosystem
Packagist
Packages
cakephp/cakephp
Severity
High
Weaknesses
CWE-20
Reviewed
2023-01-14

Affected packages

• Packagist cakephp/cakephp: >= 1.2.8, < 1.3.6 → fixed in 1.3.6

Description

The `_validatePost` function in `libs/controller/components/security.php` in CakePHP 1.3.x through 1.3.5 and 1.2.8 allows remote attackers to modify the internal Cake cache and execute arbitrary code via a crafted `data[_Token][fields]` value that is processed by the unserialize function, as demonstrated by modifying the `file_map` cache to execute arbitrary local files.

Related

Alias · CVE (1)

  • CVE-2010-4335 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x through 1.3.5 and 1.2.8 allows remote attackers to… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References