GitHub Advisoryadvisory · npm
GHSA-g374-mggx-p6xc OpenClaw: Incomplete scope-clearing fix allows operator.admin escalation via trusted-proxy auth mode
HIGH
Official page ↗
- Aliases
- CVE-2026-41404
- Ecosystem
- npm
- Packages
- openclaw
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-863
- Reviewed
- 2026-04-03
Affected packages
• npm openclaw: < 2026.3.31 → fixed in 2026.3.31
Description
Summary
Incomplete scope-clearing fix allows operator.admin escalation via trusted-proxy auth mode
Current Maintainer Triage
• Normalized severity: high
• Assessment: v2026.3.28 still misses trusted-proxy scope clearing for non-Control-UI clients, so self-declared operator scopes can survive on a real identity-bearing auth path; the complete fix is unreleased.
Affected Packages / Versions
• Package: `openclaw` (npm)
• Latest published npm version: `2026.3.31`
• Vulnerable version range: `= 2026.3.31`
• First stable tag containing the fix: `v2026.3.31`
Fix Commit(s)
• `8b88b927cb0747ad24d95b07d35682bf85dc5b0e` — 2026-03-30T14:19:00+01:00
OpenClaw thanks @north-echo for reporting.
Related
Alias · CVE (1)
- CVE-2026-41404 OpenClaw before 2026.3.31 contains an incomplete scope-clearing vulnerability in trusted-proxy authentication mode that allows… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness