GitHub Advisoryadvisory · npm
GHSA-g3r2-65gc-qpqc Denial of Service in mqtt-packet
HIGH
Official page ↗
- Aliases
- CVE-2016-10523
- Ecosystem
- npm
- Packages
- mqtt-packet
- Severity
- High
- Weaknesses
- CWE-400
- Reviewed
- 2020-06-16
Affected packages
• npm mqtt-packet: < 3.4.6 → fixed in 3.4.6
• npm mqtt-packet: >= 4.0.0, < 4.0.5 → fixed in 4.0.5
Description
Versions of `mqtt-packet` prior to 3.4.6, or 4.x prior to 4.0.5 are affected by a denial of service vulnerability wherein specific sequences of MQTT packets can crash the application.
Recommendation
Version 3.x: Update to version 3.4.6 or later.
Version 4.x: Update to version 4.0.5 or later.
Related
Alias · CVE (1)
- CVE-2016-10523 MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness