GitHub Advisoryadvisory · Packagist

GHSA-g434-3q2j-hj4r CodeIgniter Session Fixation Vulnerability

CRITICAL Published 2022-05-14 Modified 2025-06-17 Official page ↗
Aliases
CVE-2018-12071
Ecosystem
Packagist
Packages
codeigniter/framework
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-384
Reviewed
2023-07-25

Affected packages

• Packagist codeigniter/framework: < 3.1.10 → fixed in 3.1.10

Description

A Session Fixation issue exists in CodeIgniter before 3.1.10 because `session.use_strict_mode` in the Session Library was mishandled.

Related

Alias · CVE (1)

  • CVE-2018-12071 A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled. vulnerability

Weakness · CWE (1)

  • CWE-384 Session Fixation weakness

References