GitHub Advisoryadvisory · Maven
GHSA-g44m-x5h7-fr5q Apache Zeppelin: Cron arbitrary user impersonation with improper privileges
MEDIUM
Official page ↗
- Aliases
- CVE-2024-31865
- Ecosystem
- Maven
- Packages
- org.apache.zeppelin:zeppelin-server
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-20, CWE-862
- Reviewed
- 2024-04-10
Affected packages
• Maven org.apache.zeppelin:zeppelin-server: >= 0.8.2, < 0.11.1 → fixed in 0.11.1
Description
Improper Input Validation vulnerability in Apache Zeppelin.
The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges.
This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.
Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2024-31865 Improper Input Validation vulnerability in Apache Zeppelin. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-31865 advisory
- https://github.com/apache/zeppelin/pull/4631 web
- https://github.com/apache/zeppelin/commit/49e2740a1d83d58d2401ccf175fc91ffebfb0892 web
- https://github.com/apache/zeppelin package
- https://lists.apache.org/thread/slm1sf0slwc11f4m4r0nd6ot2rf7w81l web
- http://www.openwall.com/lists/oss-security/2024/04/09/9 web