GitHub Advisoryadvisory · PyPI

GHSA-g468-qj8g-vcjc TensorFlow vulnerable to `CHECK`-fail in `tensorflow::full_type::SubstituteFromAttrs`

LOW Published 2022-09-16 Modified 2022-09-16 Official page ↗
Aliases
CVE-2022-36016
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
Low
Weaknesses
CWE-617
Reviewed
2022-09-16

Affected packages

• PyPI tensorflow: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow: >= 2.9.0, < 2.9.1 → fixed in 2.9.1 • PyPI tensorflow-cpu: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-cpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1 • PyPI tensorflow-gpu: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-gpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1

Description

Impact When `tensorflow::full_type::SubstituteFromAttrs` receives a `FullTypeDef& t` that is not exactly three args, it triggers a `CHECK`-fail instead of returning a status. ```cpp Status SubstituteForEach(AttrMap& attrs, FullTypeDef& t) { DCHECK_EQ(t.args_size(), 3); const auto& cont = t.args(0); const auto& tmpl = t.args(1); const auto& t_var = t.args(2); ``` Patches We have patched the issue in GitHub commit 6104f0d4091c260ce9352f9155f7e9b725eab012. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Related

Alias · CVE (1)

  • CVE-2022-36016 TensorFlow is an open source platform for machine learning. vulnerability

Weakness · CWE (1)

  • CWE-617 Reachable Assertion weakness

References