GitHub Advisoryadvisory · PyPI

GHSA-g49j-j489-3xpf Apache Superset incorrect write permissions vulnerability

HIGH Published 2023-12-19 Modified 2025-02-13 Official page ↗
Aliases
CVE-2023-49734
Ecosystem
PyPI
Packages
apache-superset
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Weaknesses
CWE-863
Reviewed
2023-12-19

Affected packages

• PyPI apache-superset: < 2.1.3 → fixed in 2.1.3 • PyPI apache-superset: >= 3.0.0, < 3.0.2 → fixed in 3.0.2

Description

An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2023-49734 An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References