GitHub Advisoryadvisory · Maven
GHSA-g4j6-m3m3-crw8 Stored XSS vulnerability in Jenkins upstream cause
HIGH
Official page ↗
- Aliases
- CVE-2020-2221
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-24
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.235.2 → fixed in 2.235.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.236, < 2.245 → fixed in 2.245
Description
Jenkins 2.244 and earlier, LTS 2.235.1 and earlier does not escape the upstream job's display name shown as part of a build cause, resulting in a stored cross-site scripting vulnerability.
Jenkins 2.245, LTS 2.235.2 escapes the job display name.
Related
Alias · CVE (1)
- CVE-2020-2221 Jenkins 2.244 and earlier, LTS 2.235.1 and earlier does not escape the upstream job's display name shown as part of a build cause,… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2221 advisory
- https://github.com/jenkinsci/jenkins/commit/f6e575381bdba85afaf27c529d7298091f226e49 web
- https://github.com/jenkinsci/jenkins package
- https://jenkins.io/security/advisory/2020-07-15/#SECURITY-1901 web
- http://www.openwall.com/lists/oss-security/2020/07/15/5 web