GitHub Advisoryadvisory · PyPI
GHSA-g4r8-3qmh-pmch pgAdmin has vulnerability in LDAP authentication mechanism that allows bypassing TLS certificate verification
HIGH
Official page ↗
- Aliases
- CVE-2025-12765
- Ecosystem
- PyPI
- Packages
- pgadmin4
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-295
- Reviewed
- 2025-11-13
Affected packages
• PyPI pgadmin4: < 9.10 → fixed in 9.10
Description
pgAdmin <= 9.9 is affected by a vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification.
Related
Alias · CVE (1)
- CVE-2025-12765 pgAdmin <= 9.9 is affected by a vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification. vulnerability
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness