GitHub Advisoryadvisory · PyPI

GHSA-g4rw-82hq-8jpr MapProxy vulnerable to cross-site scripting in demo service

MEDIUM Published 2022-05-13 Modified 2023-10-10 Official page ↗
Aliases
CVE-2017-1000426
Ecosystem
PyPI
Packages
MapProxy
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-07-26

Affected packages

• PyPI MapProxy: < 1.11.1 → fixed in 1.11.1

Description

MapProxy version 1.11.1 and older are vulnerable to cross-site scripting in the demo service resulting in possible information disclosure. An incomplete fix was released in v1.10.4, and a complete fix was released in v1.11.1.

Related

Alias · CVE (1)

  • CVE-2017-1000426 MapProxy version 1.10.3 and older is vulnerable to a Cross Site Scripting attack in the demo service resulting in possible information… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References