GitHub Advisoryadvisory · Go
GHSA-g4v5-6f5p-m38j OpenFGA Authorization Bypass
MEDIUM
Official page ↗
- Aliases
- CVE-2025-25196
- Ecosystem
- Go
- Packages
- github.com/openfga/openfga
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- Weaknesses
- CWE-285
- Reviewed
- 2025-02-19
Affected packages
• Go github.com/openfga/openfga: < 1.8.5 → fixed in 1.8.5
Description
Overview
OpenFGA v1.8.4 or previous (Helm chart < openfga-0.2.22, docker < v.1.8.5) are vulnerable to authorization bypass when certain Check and ListObject calls are executed.
Am I Affected?
If you are using OpenFGA v1.8.4 or previous, specifically under the following conditions, you are affected by this authorization bypass vulnerability:
• Calling Check API or ListObjects with a model that has a relation directly assignable to both public access AND userset with the same type, and
• A type bound public access tuple is assigned to an object, and
• userset tuple is not assigned to the same object, and
• Check request's user field is a userset that has the same type as the type bound public access tuple's user type
Fix
Upgrade to v1.8.5. This upgrade is backwards compatible.
Related
Alias · CVE (1)
- CVE-2025-25196 OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness