GitHub Advisoryadvisory · Maven
GHSA-g56w-cwg4-hxx9 Code injection in quarkus dev ui config editor
CRITICAL
Official page ↗
- Aliases
- CVE-2022-4116
- Ecosystem
- Maven
- Packages
- io.quarkus:quarkus-vertx-http-deployment
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-94
- Reviewed
- 2022-11-23
Affected packages
• Maven io.quarkus:quarkus-vertx-http-deployment: >= 2.14.0, < 2.14.2.Final → fixed in 2.14.2.Final
• Maven io.quarkus:quarkus-vertx-http-deployment: < 2.13.5.Final → fixed in 2.13.5.Final
Description
A vulnerability was found in quarkus. This security flaw happens in Dev UI Config Editor which is vulnerable to drive-by localhost attacks leading to remote code execution.
Related
Alias · CVE (1)
- CVE-2022-4116 A vulnerability was found in quarkus. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-4116 advisory
- https://access.redhat.com/security/cve/CVE-2022-4116 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2144748 web
- https://github.com/quarkusio/quarkus package
- https://github.com/quarkusio/quarkus/discussions/29527 web
- https://github.com/quarkusio/quarkus/discussions/29527#discussioncomment-4387809 web