GitHub Advisoryadvisory · npm
GHSA-g5hg-p3ph-g8qg Multer vulnerable to Denial of Service via unhandled exception
HIGH
Official page ↗
- Aliases
- CVE-2025-48997
- Ecosystem
- npm
- Packages
- multer
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Weaknesses
- CWE-248
- Reviewed
- 2025-06-05
Affected packages
• npm multer: >= 1.4.4-lts.1, < 2.0.1 → fixed in 2.0.1
Description
Impact
A vulnerability in Multer versions >=1.4.4-lts.1, <2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to `2.0.1`
Workarounds
None
References
https://github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9
https://github.com/expressjs/multer/issues/1233
https://github.com/expressjs/multer/pull/1256
Related
Alias · CVE (1)
- CVE-2025-48997 Multer is a node.js middleware for handling `multipart/form-data`. vulnerability
Weakness · CWE (1)
- CWE-248 Uncaught Exception weakness
References
- https://github.com/expressjs/multer/security/advisories/GHSA-g5hg-p3ph-g8qg web
- https://nvd.nist.gov/vuln/detail/CVE-2025-48997 advisory
- https://github.com/expressjs/multer/issues/1233 web
- https://github.com/expressjs/multer/pull/1256 web
- https://github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9 web
- https://github.com/expressjs/multer package