GitHub Advisoryadvisory · Maven

GHSA-g5q2-cxgq-h2rw Information leak in Gerrit

LOW Published 2022-05-24 Modified 2024-01-09 Official page ↗
Aliases
CVE-2020-8920
Ecosystem
Maven
Packages
com.google.gerrit:gerrit-plugin-api
Severity
Low
Weaknesses
CWE-863
Reviewed
2024-01-09

Affected packages

• Maven com.google.gerrit:gerrit-plugin-api: < 2.14.22 → fixed in 2.14.22 • Maven com.google.gerrit:gerrit-plugin-api: >= 2.15.0, < 2.15.21 → fixed in 2.15.21 • Maven com.google.gerrit:gerrit-plugin-api: >= 2.16.0, < 2.16.25 → fixed in 2.16.25 • Maven com.google.gerrit:gerrit-plugin-api: >= 3.0.0, < 3.0.15 → fixed in 3.0.15 • Maven com.google.gerrit:gerrit-plugin-api: >= 3.1.0, < 3.1.10 → fixed in 3.1.10 • Maven com.google.gerrit:gerrit-plugin-api: >= 3.2.0, < 3.2.5 → fixed in 3.2.5

Description

An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.

Related

Alias · CVE (1)

  • CVE-2020-8920 An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References