GitHub Advisoryadvisory · Packagist

GHSA-g6h6-4fp6-w33w Moodle vulnerable to Stored Cross-site Scripting

MEDIUM Published 2023-03-07 Modified 2025-03-07 Official page ↗
Aliases
CVE-2021-36401
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-03-08

Affected packages

• Packagist moodle/moodle: >= 3.11.0-beta, < 3.11.1 → fixed in 3.11.1 • Packagist moodle/moodle: >= 3.10.0-beta, < 3.10.5 → fixed in 3.10.5 • Packagist moodle/moodle: < 3.9.8 → fixed in 3.9.8

Description

In Moodle, ID numbers exported in HTML data formats required additional sanitizing to prevent a local stored XSS risk.

Related

Alias · CVE (1)

  • CVE-2021-36401 In Moodle, ID numbers exported in HTML data formats required additional sanitizing to prevent a local stored XSS risk. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References