GitHub Advisoryadvisory · Go
GHSA-g6q4-w3j3-jfc4 Windmill HTTP Request users.rs excessive authentication in github.com/windmill-labs/windmill
MEDIUM
Official page ↗
- Aliases
- CVE-2024-8462
- Ecosystem
- Go
- Packages
- github.com/windmill-labs/windmill
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-307
- Reviewed
- 2024-09-06
Affected packages
• Go github.com/windmill-labs/windmill: <= 1.61.1 (no fix yet)
Description
A vulnerability was found in Windmill 1.380.0. It has been classified as problematic. Affected is an unknown function of the file backend/windmill-api/src/users.rs of the component HTTP Request Handler. The manipulation leads to improper restriction of excessive authentication attempts. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.390.1 is able to address this issue. The patch is identified as acfe7786152f036f2476f93ab5536571514fa9e3. It is recommended to upgrade the affected component.
Related
Alias · CVE (1)
- CVE-2024-8462 A vulnerability was found in Windmill 1.380.0. vulnerability
Weakness · CWE (1)
- CWE-307 Improper Restriction of Excessive Authentication Attempts weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-8462 advisory
- https://github.com/windmill-labs/windmill/commit/acfe7786152f036f2476f93ab5536571514fa9e3 web
- https://github.com/windmill-labs/windmill package
- https://github.com/windmill-labs/windmill/releases/tag/v1.390.1 web
- https://pkg.go.dev/vuln/GO-2024-3118 web
- https://vuldb.com/?ctiid.276630 web
- https://vuldb.com/?id.276630 web
- https://vuldb.com/?submit.401826 web