GitHub Advisoryadvisory · Maven
GHSA-g6rx-6wfx-gj74 Bouncy Castle for Java has Out-of-Bounds Write Vulnerability
LOW
Official page ↗
- Aliases
- CVE-2025-9340
- Ecosystem
- Maven
- Packages
- org.bouncycastle:bc-fips
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:P/AC:L/AT:P/PR:L/UI:A/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:X/R:U/V:X/RE:M/U:Green
- Weaknesses
- CWE-787
- Reviewed
- 2025-08-22
Affected packages
• Maven org.bouncycastle:bc-fips: >= 2.1.0, < 2.1.1 → fixed in 2.1.1
Description
Out-of-bounds Write vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java bc-fips on All (API modules). This vulnerability is associated with program files org/bouncycastle/jcajce/provider/BaseCipher.
This issue affects Bouncy Castle for Java: from BC-FJA 2.1.0 through 2.1.0.
Related
Alias · CVE (1)
- CVE-2025-9340 Out-of-bounds Write vulnerability in Legion of the Bouncy Castle Inc. vulnerability
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness