GitHub Advisoryadvisory · Go
GHSA-g78f-6xq7-rrhq Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials
CRITICAL
Official page ↗
- Aliases
- CVE-2017-18885
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
- Reviewed
- 2025-12-05
Affected packages
• Go github.com/mattermost/mattermost-server: < 4.1.2 → fixed in 4.1.2
• Go github.com/mattermost/mattermost-server: >= 4.2.0-rc1, < 4.2.1 → fixed in 4.2.1
• Go github.com/mattermost/mattermost-server: >= 4.3.0-rc1, < 4.3.0 → fixed in 4.3.0
Description
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. It allows attackers to gain privileges by accessing unintended API endpoints on a user's behalf.
Related
Alias · CVE (1)
- CVE-2017-18885 An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness