GitHub Advisoryadvisory · Packagist

GHSA-g7pj-3v97-3vxp Pimcore Vulnerable to PHP Object Injection Attacks

HIGH Published 2022-05-17 Modified 2025-04-13 Official page ↗
Aliases
CVE-2014-2921
Ecosystem
Packagist
Packages
pimcore/pimcore
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
Weaknesses
CWE-94
Reviewed
2023-08-16

Affected packages

• Packagist pimcore/pimcore: >= 1.4.9, < 2.2.0 → fixed in 2.2.0

Description

The `getObjectByToken` function in `Newsletter.php` in the `Pimcore_Tool_Newsletter` module in pimcore 1.4.9 through 2.0.0 does not properly handle an object obtained by unserializing Lucene search data, which allows remote attackers to conduct PHP object injection attacks and execute arbitrary code via vectors involving a `Zend_Pdf_ElementFactory_Proxy` object and a pathname with a trailing `\0` character.

Related

Alias · CVE (1)

  • CVE-2014-2921 The getObjectByToken function in Newsletter.php in the Pimcore_Tool_Newsletter module in pimcore 1.4.9 through 2.0.0 does not properly… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References