GitHub Advisoryadvisory · RubyGems

GHSA-g7xq-xv8c-h98c Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags

HIGH Published 2024-04-17 Modified 2024-04-19 Official page ↗
Aliases
CVE-2024-32463
Ecosystem
RubyGems
Packages
phlex
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Weaknesses
CWE-79, CWE-87
Reviewed
2024-04-17

Affected packages

• RubyGems phlex: >= 1.10.0, < 1.10.1 → fixed in 1.10.1 • RubyGems phlex: >= 1.9.0, < 1.9.2 → fixed in 1.9.2 • RubyGems phlex: >= 1.8.0, < 1.8.3 → fixed in 1.8.3 • RubyGems phlex: >= 1.7.0, < 1.7.2 → fixed in 1.7.2 • RubyGems phlex: >= 1.6.0, < 1.6.3 → fixed in 1.6.3 • RubyGems phlex: >= 1.5.0, < 1.5.3 → fixed in 1.5.3 • RubyGems phlex: < 1.4.2 → fixed in 1.4.2

Description

Summary There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. Our filter to detect and prevent the use of the `javascript:` URL scheme in the `href` attribute of an `` tag could be bypassed with tab `\t` or newline `\n` characters between the characters of the protocol, e.g. `java\tscript:`. Impact If you render an `` tag with an `href` attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user. ```ruby a(href: user_profile) { "Profile" } ``` Mitigation The best way to mitigate this vulnerability is to update to one of the following versions: • 1.10.1 • 1.9.2 • 1.8.3 • 1.7.2 • 1.6.3 • 1.5.3 • 1.4.2 Workarounds Configuring a Content Security Policy that does not allow `unsafe-inline` would effectively prevent this vulnerability from being exploited.

Related

Alias · CVE (1)

  • CVE-2024-32463 phlex is an open source framework for building object-oriented views in Ruby. vulnerability

Weakness · CWE (2)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness
  • CWE-87 Improper Neutralization of Alternate XSS Syntax weakness

References